Unusual Spinning icon issue

New Install of Yourls and it’s bugged by the spinning icon issue.
Read everything I can find on this and can’t see any mention of anything similar.

If I open up the Chrome developer console I can see a failed GET request for

http://ethanro.se/admin/admin-ajax.php?action=add&url=http%3A%2F%2Fwww.foo.bar&keyword=&nonce=f****ceadd with the error net:ERR_FAILED

The status shows failed and the initiator: jquery-3.3.1.min.js?v=1.7.9:2

If I paste the above URL manually into a browser, then a load of JSON is returned and the Short Link is created and it appears in the Admin console - so that part seems to be working

Interestingly if I look at the header request, I can see that the Host and the Origin are different (one has www prefix). Could that be the issue and if so, how to fix ?

GET /admin/admin-ajax.php?action=add&url=http%3A%2F%2Fwww.foo.bar&keyword=&nonce=f****ceadd HTTP/1.1
Host: ethanro.se
Connection: keep-alive
Accept: application/json, text/javascript, /; q=0.01
User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.97 Safari/537.36
Origin: http://www.ethanro.se
Referer: www.ethanro.se/admin/ <= has http prefix but forum only allows me two URLS in post
Accept-Encoding: gzip, deflate
Accept-Language: en-GB,en-US;q=0.9,en;q=0.8

How is defined YOURLS_SITE in your config, with or without www ? Do you have something at server config level, or htacess, that rewrites www to non-www or vice-versa ?

This is the definition so without WWW.
define( ‘YOURLS_SITE’, ‘http://ethanro.se’ );

The server’s hosted with Dreamhost and the domain has this option set
Add WWW: Make http://ethanro.se/ redirect to http://www.ethanro.se/

Changing the define( ‘YOURLS_SITE’, ‘http://www.ethanro.se’ ); seems to have fixed the issue.

Many thanks