It seems Instant shorten (and other Bookmarklets) don't work in Firefox anymore

Hello dear community,

can someone confirm that the Instant Shorten Bookmarklet does not work anymore? Or is it an individual problem on my end.

I am using YOURLS 1.7.9 and everything is working fine, with 120 working shortlinks so far. But since the last Firefox update I noticed that Instant Shorten does not work anymore. Opening the Console I am seeing this: 2020-06-07 00_51_26-Window

This error occurs on every site I tried to create a shortlink. Interestingly, on my YOURLS Site the Instant Shorten Bookmark does work and the javascript window does open.

Any ideas?

I would like to add, that the problem also exists in Chrome, but the console output is different:

Have you tried on non HTTPS, just HTTP, sites ?

Both http and https renders the same result.

Standard Shorten does work btw. In fact, disregard other Bookmarklets from first post. Only Instant Shorten is affected.

The bookmarklet works as expected for me. Try it for instance on this page: https://yourls.org/somestats

The thing is, and that’s not new: depending on server config, sites can prevent injection of third party JS, which happens on a very lot of sites.

The next version of YOURLS will display a message about this. In short: don’t use the instant bookmarklets.

Even on the link you gave, the Instant shorten does not work and renders the same console output as shown in the images above.
I’ll switch over to standard “Shorten” bookmarklet, as this is still working for me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.