Empty screen on install

After uploading all files to my server, and configuring /user/config.php, I point my browser to https://subdomain.mysite.com/admin/.

I see the yourls logo. I have debugging ‘on’, and, underneath the ‘Install YOURLS’ button, I can see this notice (of course {{db}} is a placeholder):

Connected to database {{my db}} on mysql.mysite.com
SQL: SHOW TABLES LIKE ‘yourls_options’ (0.00035 s)

So, yourls can see the db.

Pressing ‘Install YOURLS’ results in an empty screen (on Safari) or a HTTP ERROR 500 (on Chrome). The console is also empty.

I’m running PHP7.3 on Apache on Ubuntu 14.04.6 LTS.
I have YOURLS running on another domain on the same server. (But not on a subdomain).

Turning on PHP debugging shows this error message after pressing ‘Install YOURLS’:

Fatal error : Uncaught PDOException: SQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 767 bytes in /home/{{websitefolder}}/includes/vendor/aura/sql/src/ExtendedPdo.php:748 Stack trace: #0 /home/{{websitefolder}}/includes/vendor/aura/sql/src/ExtendedPdo.php(748): PDOStatement->execute() #1 /home/{{websitefolder}}/includes/functions-install.php(252): Aura\Sql\ExtendedPdo->perform(‘CREATE TABLE IF…’) #2 /home/{{websitefolder}}/admin/install.php(46): yourls_create_sql_tables() #3 {main} thrown in /home/{{websitefolder}}/includes/vendor/aura/sql/src/ExtendedPdo.php on line 748

How to resolve this?

See https://github.com/YOURLS/YOURLS/issues/2734

Thanks for pointing me there.

I tried this, which changed nothing.

What worked for me was changing the character encoding of my database to utf8.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.