Custom keywords have letters removed - play becomes pay

Not sure if this is a bug/feature/plugin request.
I have the random ShortURLs plugin enabled so that I don’t have sequential urls on my site which is great, however sometimes I want to use a custom keyword such as play.
I’ve noticed that the l’s 1’s and other similar characters are removed from the custom url so play becomes pay.
Unfortunately this has quite a different connotation when you are encouraging users to play with a system but the url says pay!

Is there an option in either core or the random shortcut (or another plugin) that allows the custom keywords to stick with whatever character combination I choose, but the randomly generated keyword to avoid the similar characters - uppercase i and lower case L for example.

I cannot reproduce this. You probably have another plugin enabled (or something in your config?), that dictates a custom short URL charset.

Thanks @ozh. I checked the other plugins and had the simplecharset plugin enabled. I’ve removed that and can now have play and client as keywords.
Thanks for the follow up!