Blank Page - Install Impossible

Hi,

I tried to install YOURLS on my Debian 10 Server but it failed.
PHP 7.3

I have a blank page when i click on the install button.

https://mysite.com/admin/install.php? is empty, even with debug mode activated.
In the console i have nothing except : “** dataslayer: injecting Launch monitors **”

Could you help ?

Neuron

The browser console will not give information about server error. See https://github.com/YOURLS/YOURLS/wiki/Troubleshooting-first-steps

I gave everything i add, even if i know the console doesn’t give information about server error.
But the debug mode give me nothing also.
So i don’t know what to do.

Did you check server logs ?

It seems there is an issue with the connection with the database

[Thu Jun 18 07:27:59.507843 2020] [proxy_fcgi:error] [pid 11622] [client XX.XXX.226.100:4096] AH01071: Got error 'PHP message: PHP Fatal error: Uncaught PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'database.yourls_options' doesn't exist in /var/www/clients/abc/web/includes/vendor/aura/sql/src/ExtendedPdo.php:748\nStack trace:\n#0 /var/www/clients/abc/web/includes/vendor/aura/sql/src/ExtendedPdo.php(748): PDOStatement->execute()\n#1 /var/www/clients/abc/web/includes/vendor/aura/sql/src/ExtendedPdo.php(545): Aura\\Sql\\ExtendedPdo->perform('SELECT option_v...', Array)\n#2 /var/www/clients/abc/web/includes/Database/Options.php(110): Aura\\Sql\\ExtendedPdo->fetchOne('SELECT option_v...', Array)\n#3 /var/www/clients/abc/web/includes/functions.php(1140): YOURLS\\Database\\Options->get('version', false)\n#4 /var/www/clients/abc/web/includes/functions.php(1110): yourls_get_option('version')\n#5 /var/www/clients/abc/web/includes/functions.php(1094): yourls_get_current_version_from_sql()\n#6 /var/www/clients/abc/web...'

That’s strange because the database exist. I will recheck the typo

What could be wrong ?

<?php
/* This is a sample config file.
 * Edit this file with your own settings and save it as "config.php"
 *
 * IMPORTANT: edit and save this file as plain ASCII text, using a text editor, for instance TextEdit on Mac OS or
 * Notepad on Windows. Make sure there is no character before the opening <?php at the beginning of this file.
 */

/*
 ** MySQL settings - You can get this info from your web host
 */

/** MySQL database username */
define( 'YOURLS_DB_USER', 'userdatabase' );

/** MySQL database password */
define( 'YOURLS_DB_PASS', 'password' );

/** The name of the database for YOURLS */
define( 'YOURLS_DB_NAME', 'database' );

/** MySQL hostname.
 ** If using a non standard port, specify it like 'hostname:port', eg. 'localhost:9999' or '127.0.0.1:666' */
define( 'YOURLS_DB_HOST', 'localhost' );

/** MySQL tables prefix */
define( 'YOURLS_DB_PREFIX', 'yourls_' );

/*
 ** Site options
 */

/** YOURLS installation URL -- all lowercase, no trailing slash at the end.
 ** If you define it to "http://sho.rt", don't use "http://www.sho.rt" in your browser (and vice-versa) */
define( 'YOURLS_SITE', 'https://mysite.eu' );

Anything could be wrong:

  • mysql server not running
  • mysql server not reachable on that host and/or port
  • … ?

I installed Wordpress, Drupal, Forum CMS on it without issue.
First time it happens.

Ok, error found. YOURLS doesn’t support UTF8MB4 format.
So i recreate a new database with only UTF8

Current dev version of YOURLS is all utf8mb4