After updating, SURL was truncated

A probable bug, I’m not sure, but after upgrading to the latest version, 1.7.3, one of my short url stop working. When I check the url it got truncated from ChemSAC to hem. And strangely I couldn’t edit or do anything on the entry.

When I check my database, the entry with ChemSAC is there but on the interface it shows only hem

So, I manually deleted from database, and re-add the url, but strange enough, I couldn’t do so. it always got truncated to hem.

Is it that capitalization is not allowed anymore?

Opps, my bad, I found the problem, during update, I did by mistake replaced the config.php file and totally forgot to change this part

define( 'YOURLS_URL_CONVERT', 36 );

So, anyway, I hope this would help others. During my first install I’ve used

define( 'YOURLS_URL_CONVERT', 62 );

But by default the config file is set to 36, and after editing all other options, I forgot that part.

Wow, that’s a quick resolution!
I’m happy you found the solution.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.